PHP Composer – Could not parse version constraint

При виникненні такої помилки:

[root@web /home/web/www/mail]# composer install
Loading composer repositories with package information
Initializing PEAR repository http://pear.php.net
Installing dependencies (including require-dev)

[RuntimeException]
Could not load package phpspec/prophecy in http://packagist.org: [UnexpectedValueException] Could not parse version constraint ^1.0.2: Invalid version string ^1.0.2″

[UnexpectedValueException] Could not parse version constraint ^1.0.2: Invalid version string “^1.0.2”

install [–prefer-source] [–prefer-dist] [–dry-run] [–dev] [–no-dev] [–no-plugins] [–no-custom-installers] [–no-scripts] [–no-progress] [-v|vv|vvv|–
verbose] [-o|–optimize-autoloader] [–ignore-platform-reqs] [packages1] … [packagesN]

Рішенням цієї помилки є, оновлення Composer, це можна зробити командою само-оновлення:

composer selfupdate

Джерело

 

Noctua маркування

0489685

Модель розшифровка опис
NF-F Focused Flow для вільного але сфокусованого повітряного потоку
NF-A Air Flow для вільного але не сфокусованого повітряного потоку
NF-S Silence (Aimed at nothing but silence) не спеціалізований тип, має на меті безшумну роботу, завдяки малії кількості обертів
NF-P Pressure статичний тиск та спрямований потік, для місць де є обмеження повітряному потоку (фільтри, сітка чи радіатор)
NF-R Raised blade для малих розмірів, з малою кількістю обертів
NF-B Beveled blade між потоком повітря та тишею

FreeBSD qjail та postgresql

При ініціалізації (/usr/local/etc/rc.d/postgresql initdb) структури, з’являється помилка:

creating template1 database in /usr/local/pgsql/data/base/1 ... FATAL:  could not create shared memory segment: Function not implemented

Для вирішення цієї проблеми потрібно в джейлі увімкнути можливість System V IPC (Semaphores and Shared Memory).

В qjail:

qjail config -y "ім’я jail"

Для звичайного Jail, додайте у файл  /etc/jail.conf:

jail-ім'я {
allow.sysvipc;
}

Виконувати коли джейл вимкнений.

 

FreeBSD pkg та proxy

Якщо вихід до мережі інтернет, можливий лише через proxy. А вам необхідно працювати з ports ОС FreeBSD.

Треба налаштувати систему на використання proxy:

Якщо командний інтерпрітатор – csh

у файл /etc/csh.cshrc додати:

setenv HTTP_PROXY http://proxy:3128

Якщо командний інтерпрітатор – sh

у файл /etc/profile додати:

HTTP_PROXY=http://proxy:3128
export HTTP_PROXY